Adding protocols


#1

Hi Charles,
I have experience a glitch I think when I try to add a protocol in the middle of an existing experiment, it automatically appears at the end of the section. I then need to copy paste it where I want it.
Second: I have some tables that are invisible when I add a protocol (but they are in the protocol), I then need to copy them (from the handy icon) and paste them just after the invisible one and delete the invisible one. It approximately take 2 seconds but could be fixed.

This software is still making my hectic day manageable.


#2

Hi Remi,

Thanks for the bug reports!

For the protocol insertion, it’s indeed the wanted behavior to add it after the current section, or at the end of the day, to avoid the confusion of having everything after the inserted protocol become part of that protocol (in the sense that lower level headers will be hierarchically under it). I am happy to change the behavior, but could you explain with an example what content you have below the protocol that you would like to remain there? Though now that I tried it, I see that inserted protocols are pushed below even level-1 headers, which would actually not be affected by the protocol even if it was inserted before. I need to check the code, but it’s likely I am just adding at the end of the current day, and the behavior could be more fine-grained. I suppose one could argue the user should know what it’s doing… Thanks for your feedback on this.

I’ll check the table insertion bug too…

Charles